Semantic Web – WordPress

Google Maps API – Lunascape4 Version 4.8.x – KsGMap

leave a comment »

汎用Google Maps APIスクリプト「KsGMap」
 http://www.ksgmap.jp/
によるウェブマップのサイトをブラウザ Lunascape4 Version 4.8.1
 http://www.lunascape.jp/
(2009-01-09時点では、最新の正式日本語版)
でアクセスすると、

 本バージョンのKsGMapはGoogle Maps API Ver2 でのみ動作します。
 Google の APIキーを入力する所の v=1 を v=2 にして下さい。

Lunascape4 Version 4.8.1:Google Maps APIのバージョン誤認

と表示されます。javascriptは正しく記述してありますので、

 SRWare Iron 1.0.155.0
 Google Chrome 1.0.154.36
 Firefox /3.0.5
 Windows Internet Explorer7 バージョン 7.0.5730.13
 Lunascape Lite Ver 4.0.1(ブラウザエンジン IE (Trident))

などのブラウザではエラー/警告ダイアログは表示されません。

Lunascape掲示板
 http://bbs.lunascape.jp/BBSList.aspx
の「不具合掲示板」に報告しました。

Google Maps APIのバージョン誤認」投稿日時: 2009/01/09 11:42:36
Lunascape4 Version 4.8.1 / Unicode
ブラウザエンジン Gecko 使用 [未使用 IE (Trident)]
OS Windows 2000 SP4 および WindowsXP SP3で発生しました。

Google Maps APIを利用するウェブマップでは、通常、ホームページのheadタグ内に
Google Maps API Key を指定した javascript
(例)<script src="http://maps.google.co.jp/maps?file=api&v=2&datum=wgs84&key=省 略" type="text/javascript"></script>
の1行を挿入しますが、

上記のとおりGoogle Maps API version 2に準拠した記述であっても、version 1と誤認し、ダイアログ表示することがあります。再アクセス後に自然復旧し、再現困難のため検証はできませんでしたが、報告いたします。
因みに、
Lunascape Lite Ver 4.0.1
ブラウザエンジン IE (Trident)限定
では、このようなエラーは発生しません。

Written by support

2009/01/09 @ 21:15

カテゴリー: Browser

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

%d人のブロガーが「いいね」をつけました。