Semantic Web – WordPress

Movable Typeプラグイン「SubCategories 1.2」のアンインストールが先です。

leave a comment »

David Raynes さんのプラグイン「SubCategories 1.2」はとても便利なツールで、Movable Type version 3.01D までは正常に稼働します。Movable Type 3.11以降は本体のサブカテゴリー新機能を利用すればよいので、Movable Typeアップグレード後は本プラグインは不要となります。
    最新版 SubCategories 1.2 [June 21, 2004] (04/9/8現在)
    ホームページ http://www.rayners.org/
    圧縮ファイル名 subcats-1.2.tar.gz, subcats-1.2.zip
【注意事項】
■ プラグイン「SubCategories 1.2」は、新規インストールないしアップグレード版のMovable Type 3.11英語版では正常に稼働しませんでした。ブラウザIE にて mt.cgiにアクセスすると、「HTTP 500 – 内部サーバー エラー」となります。
【subcats-1.2.* 展開後の全ファイルとアップロード先】
    ベースフォルダ内 mt-sc.cgi
    pluginsフォルダ内 sub_cats.pl
    /extlib/rayners フォルダ内 SubCategory.pm SubCats.pm
    このうち、sub_cats.plを削除するだけで、正常作動します。
【とても重要なこと】
×「SubCategories 1.2」のファイルをすべてアンインストールしないで、MT3.01D からMT 3.11へアップグレードすると、カテゴリがすべて消失します(エントリのみ保存されます)。
全ファイルをアンインストール後に、MT 3.11へアップグレードすると、カテゴリも保存されます(すべてのエントリがトップの階層になります)。 MT 3.11へアップグレード後 plugin-to-db.cgi を実行します。
SubCategories Plugin Data Migration
http://www.rayners.org/2004/09/07/subcategories_plugin_data_migration/index.php
⇒ Important Note: When upgrading to a 3.1x version of MT, remove all of the files associated with the SubCategories plugin before starting the upgrade.
■ plugin-to-db.cgi の実行
上記ホームページから plugin-to-db.txtをダウンロードし、mt.cgiと同じベースディレクトリにアップロードし plugin-to-db.cgi とリネームし、ファイル属性を 700(Xrea.comさんのサーバー)に変更後、ブラウザから実行します。
Setting the parent of *** to category id **.
Done migrating your data! All went well.
もし、誤ってアップグレード前に実行すると、
You have not yet upgraded to the 3.0 version of MT. Please do that before you run this script. Exiting…
とエラーが表示されます。

Written by support

2004/09/08 @ 21:28

カテゴリー: ブログ blog

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

%d人のブロガーが「いいね」をつけました。